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While the best efforts have been made in preparing this manuscript, no liability is assumed by the authors
with respect to the use of the information provided.
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plications, as well as to diagnostic laboratories where speed, efficiency and continuity are of primary impor-
tance. Our software thanks its current status for a part to the response of many customers worldwide. Please
contact us if you have any problems or questions concerning the use of BioNumerics R©, or suggestions for
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The BioNumerics R© software, its plugin tools and their accompanying guides are subject to the terms and
conditions outlined in the License Agreement. The support, entitlement to upgrades and the right to use
the software automatically terminate if the user fails to comply with any of the statements of the License
Agreement. No part of this guide may be reproduced by any means without prior written permission of the
authors.

Copyright c©1998, 2018, Applied Maths NV. All rights reserved.

BioNumerics R© is a registered trademark of Applied Maths NV. All other product names or trademarks are
the property of their respective owners.
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BioNumerics R© uses following third-party software tools and libraries:

• The Python R© 2.7.4 release from the Python Software Foundation (http://www.python.org/).

• A library for XML input and output from the Apache Software Foundation (http://www.apache.
org).

• NCBI toolkit version 2.2.10 (http://www.ncbi.nlm.nih.gov/BLAST/).

• The Boost c++ libraries (http://www.boost.org/).

• Samtools for interacting with SAM / BAM files (http://www.htslib.org/download/)

• The 7-Zip command line version (7za.exe) from 7-Zip, copyright 1999-2010 Igor Pavlov. http:

//www.7-zip.org/

• Velvet for Windows, source code can be downloaded from http://www.applied-maths.com/

download/open-source.

• Ray for Windows, source code can be downloaded from http://www.applied-maths.com/download/

open-source.

• Mothur for Windows, source code can be downloaded from http://www.applied-maths.com/

download/open-source.

• Cairo 2D graphics library version 1.12.14 (http://cairographics.org/).

• Crypto++ Library version 5.5.2 (http://www.cryptopp.com/).

• libSVM library for Support Vector Machines (http://www.csie.ntu.edu.tw/~cjlin/libsvm/).

• SQLite version 3.7.17 (http://www.sqlite.org/).

• Gecko engine version 21 (https://developer.mozilla.org/en-US/docs/Mozilla/Gecko).

• pymzML Python R© module for high throughput bioinformatics on mass spectrometry data (https:
//github.com/pymzml/pymzML).

• Numpy Python R© library version 1.8.1 (http://www.numpy.org/).

• BioPython Python R© library version 1.64 (http://www.biopython.org/).

• PIL Python library R© version 1.1.7 (http://www.pythonware.com/products/pil/).

• The SPAdes genome assembler version 3.7.1 (http://bioinf.spbau.ru/spades).
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Chapter 1

Starting and setting up BioNumerics

1.1 Introduction

This guide is designed as a tutorial for the SmartFinder plugin. The minimal configuration for the installation
of this plugin includes the Trend data module (for the storage of the melt and peak curves) and the Character
data module (storage of the calls). For more information about the different modules of the BioNumerics
software, see the Reference manual, Chapter The concepts of BioNumerics.

For more information about the SmartFinder technology, see http://www.pathofinder.com/technology.

1.2 Startup program

When BioNumerics is launched from the Windows start panel or when the BioNumerics shortcut ( ) on
your computer’s desktop is double-clicked, the Startup program is run. This program shows the BioNu-
merics Startup window (see Figure 1.1).

A new BioNumerics database is created from the Startup program by pressing the button.

An existing database is opened in BioNumerics with or by simply double-clicking on a database
name in the list.

1.3 Creating a new database

3.1 Press the button in the BioNumerics BioNumerics Startup window to enter the New database
wizard.

3.2 Enter a name for the database, and press <Next>.

A new dialog box pops up, prompting for the type of database (see Figure 1.2).

3.3 Since we want to create a new database to demonstrate the features of the plugin, leave the default option
selected and press <Next>.

A new dialog box pops up, prompting for the database engine (see Figure 1.3).

3.4 Leave the default option selected and press <Next>.

http://www.pathofinder.com/technology
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Figure 1.1: The BioNumerics Startup window.

Figure 1.2: The New database wizard page.

3.5 Press <Finish> to complete the setup of the new database.

The Plugins dialog box appears.

1.4 Installing the SmartFinder plugin

If a database is opened for the first time, the Plugins dialog box will appear by default (see Figure 1.4).

If the database has already been opened previously, the Plugins dialog box can be called from the Main
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Figure 1.3: The Database engine wizard page.

window by selecting File > Install / remove plugins... ( ).

Figure 1.4: The Plugins dialog box.

When a particular plugin is selected from the list of plugins, a short description appears in the right panel.

A selected plugin can be installed with the <Activate> button. The software will ask for confirmation
before installation. Some plugins depend on functionality offered by specific BioNumerics modules. If a
required module is missing, the plugin cannot be installed and an error message will be generated.

Once a plugin is installed, it is marked with a green V-sign. It can be removed again with the <Deactivate>
button.

If the selected plugin is documented, pressing <Show Manual> will open its manual in the Help window.

4.1 Select the SmartFinder plugin from the list in the Applications tab and press the <Activate> button.
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The installation of the SmartFinder plugin requires administrator privileges.

4.2 The program will ask to confirm the installation of the plugin. Press <Yes> to confirm the installation.

The License string dialog box pops up (see Figure 1.5). The SmartFinder plugin can only be installed and
activated with a valid plugin license string, which needs to be purchased from Applied Maths.

Figure 1.5: The License string dialog box.

The License string dialog box prompts for the license string that is compatible with the Software Serial
Number listed in the dialog box.

4.3 Enter the six digits license string and press <OK>.

4.4 Press <Proceed> (or <Exit>) to close the Plugins dialog box and to continue to the Main window.

4.5 Close and reopen the database to activate the features of the SmartFinder plugin.

The SmartFinder plugin installs menu items in the Main window under the menu SmartFinder (see Figure
1.6).

Figure 1.6: SmartFinder menu items in the Main window.

1.5 Managing kit definitions

Since the SmartFinder plugin is compatible with several kits developed by PathoFinder B.V., the first step
after installation of the plugin will be the import of the correct kit definitions.

Selecting SmartFinder > Manage kits in the Main window calls the Manage SmartFinder kits dialog box
as depicted in Figure 1.7.

On the left side of the dialog box, a list with Imported SmartFinder kits is displayed (initially empty).

To remove the highlighted kit from the list press <Remove>. A confirmation message will appear.

When pressing the <Export> button, the highlighted kit definition will be exported as a text file and opened
in the default text editor, e.g. Notepad.
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Figure 1.7: The Manage SmartFinder kits dialog box.

An exported kit definition can be edited and then imported again to make changes to the probe
mix definition, e.g. in case new control probes were added to the mix.

Pressing <Add> will display the Select SmartFinder kit dialog box (see Figure 1.8).

Figure 1.8: The Select SmartFinder kit dialog box.

Two options are available for importing a SmartFinder kit definition:

• Kit definition provided by plugin: One of the kit definitions that were developed by PathoFinder B.V.
and which come with the plugin can be selected from the list below.

• Kit definition from file: A custom kit definition that is contained in an external file can be imported
by browsing for the kit definition file.

Pressing <Next> displays the SmartFinder kit experiments dialog box.

The SmartFinder kit experiments dialog box asks for the Kit experiment name, as it will be used in the name
of the corresponding experiment types in the BioNumerics database. The name can be edited if desired.

In case that the same SmartFinder kit is run on different real-time PCR machines (e.g. on Rotor-
Gene and LC480), it is recommended to create a different experiment type per machine, for
example by using the machine name as suffix.
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Figure 1.9: The SmartFinder kit experiments dialog box.

Pressing <Finish> creates the corresponding experiment types in the BioNumerics database and adds the
kit to the Manage SmartFinder kits dialog box.

Selecting <Close> in the Manage SmartFinder kits dialog box closes the dialog box.
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SmartFinder data import

The SmartFinder plugin is compatible with data generated with Rotor-Gene and LightCycler 480 real-time
PCR instruments. After finishing the analysis of the run, an export file has to be generated by the Rotor-Gene
or LC 480 software, respectively. This export file can be imported by the SmartFinder plugin.

• Rotor-Gene: An export file can be generated by saving the run as an Excel Data Sheet using the
Rotor-Gene software. Select File > Save as... > Excel data sheet to save the run data.

• LightCycler 480: When using an LC480, both the run file and the corresponding Color Compensation
run file have to be exported.

– Open the Navigator in the LC480 software by clicking .

– Select the run file you want to export.

– By clicking , a new window opens.

– Select the appropriate location and the correct file format: Experiment Text File (*.txt). Please
make sure that you export the Color Compensation run file and NOT the Color Compensation
file which is generated by the LC 480 software.

Before importing data, one needs to decide where to store the sample numbers: they can be stored in the
’Key’ field (the unique identifier in a BioNumerics database) or in a dedicated information field. In the latter
case, a new information field should be created before importing any SmartFinder data. Sample numbers
should be unique and it is good practice to employ consistent naming conventions. A new information field
can be added to the database with Edit > Information fields > Add information field....

Selecting SmartFinder > Import data opens the first page of the import wizard (see Figure 2.1), which will
guide the user through the import process.

With the <Browse> button, one can browse for a data file on the local computer or on a network drive. The
full path will then be displayed next to File name.
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Figure 2.1: The Import dialog box.

From the File format drop-down list, the file format that corresponds to the data file at hand can be selected.
Options are LightCycler 480 and Rotor-Gene. For LightCycler 480, *.txt and *.xml files are supported; for
Rotor-Gene, *.txt and *.csv files can be used.

With the SmartFinder kit drop-down list, any of the installed SmartFinder kits (see 1.5) can be selected.
The kit that was used to generated the data, should be selected here.

A Color compensation step is only needed for LightCycler data. This option is inactive for Rotor-Gene,
since these data are already compensated for cross-talk between the different channels by the software of the
real-time PCR apparatus. When LightCycler 480 is selected from the File format drop-down list, pressing
<Manage> will open the Manage LC480 color compensation dialog box (see Figure 2.2).

Figure 2.2: The Manage LC480 color compensation dialog box.

From this dialog box, color compensation runs can be added and removed:

• Pressing <Add> will prompt you to <Browse> for a File name of a color compensation file. The
name that will be used to refer to this color compensation run file can be entered next to CC name.

• A highlighted color compensation run file can be deleted with <Remove>. The software will ask for
confirmation before actually removing the file.
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Once a color compensation file is added via the Manage LC480 color compensation dialog box, it can be
selected from the Color compensation drop-down list in the Import dialog box to correct the LightCycler
data during import.

BioNumerics only stores the color-compensated data, not the raw, uncorrected data. Therefore,
if you want to use a different color compensation run to correct data for, the corresponding
LightCycler files need to be imported again.

The settings for the melt curve analysis can be accessed by pressing <Analysis settings> and are further
discussed in 3.3.

Pressing <Next> will display the second page of the wizard (see Figure 2.3).

Figure 2.3: The Samples dialog box.

This page provides an editable preview of how the data will be parsed from the data file. A grid is displayed
with following fields:

• File sample: The sample name as used in the data file.

• Type: The type of sample, which can be one of following values:

– ”Sample” (a normal (patient) sample to be analyzed),

– ”Negative control” (a no template control (NTC) or blank), or

– ”Empty” (an empty well that should be excluded from the import).

• Reaction: The reaction mix (”Mix 1” or ”Mix 2”) that the sample belongs to.

• Sample: The name of the sample as it will be used in the database.

The Type and Reaction can be edited for samples individually by selecting one of the predefined values
from the drop-down list. The Sample field can be edited directly via the keyboard.

Parsing of the sample names will occur automatically if following naming convention was
followed: <SampleName><Delimiter><MixName>. The <Delimiter> can be a space, un-
derscore, etc..
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Samples that are labeled ”Blanco” will be automatically recognized as negative controls.

A warning message will appear when attempting to import samples without sufficient negative control sam-
ples (at least one negative control sample per reaction mix should be present) or when non-unique sample
numbers were encountered.

Pressing <Next> will display the final page of the import wizard (see Figure 2.4).

Figure 2.4: The Database dialog box.

From the drop-down list next to Link sample names to, the database field to hold the sample number needs
to be selected.

Optionally, the File name and File creation date information can be linked to non-default information fields
(if defined in the database).

The option Create new entries should normally be checked during import. It can be unchecked to make
sure that no new entries are being added during an import of previously analyzed data.

If Overwrite existing entries is checked, samples with the same name as in the data file can be overwritten.

Checking Select imported entries will select imported samples. This feature makes it easier to retrieve the
last imported samples in large databases.

Pressing <Finish> will start the import.
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Melting curve analysis

3.1 The SmartFinder analysis window

After an import, the SmartFinder analysis window (see Figure 3.2) appears for the imported samples.

Alternatively, the SmartFinder analysis window can be opened for any selection of entries with SmartFinder
> Analyze data. If more than one kit is defined in the database, the Select SmartFinder kit dialog box is
displayed (see Figure 3.1).

Figure 3.1: The Select SmartFinder kit dialog box.

Select a kit to analyze from the list and press <OK> to open the SmartFinder analysis window.

The SmartFinder analysis window consists of three panels:

• The Entries panel displays for each of the samples the same information fields as in the Main window
and a colored cell per probe in the probe mix. The colors are determined in the character type experi-
ment that corresponds to the probe mix. By default, they are green for a negative reaction and red for
a positive reaction.

• The Analysis panel displays the curves for the highlighted entry in the Entries panel. They are orga-
nized in columns by reaction (Mix 1 and Mix 2) and in rows by channel (Rox, Cy5 and BHQ). See
3.2 for the display options of this panel.

• The Report panel shows a detailed report for the highlighted entry in the Entries panel. The report
contains information fields, the results (positive or negative) for each of the probes, the analysis set-
tings used and miniatures of the curves. For more information about reports, see 3.6.

With File > Exit, the SmartFinder analysis window can be closed again.
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Figure 3.2: The SmartFinder analysis window.

3.2 Display settings

A number of display settings for the Analysis panel can be specified via Analysis > Display settings. This
pops up the SmartFinder display settings dialog box (see Figure 3.3).

Figure 3.3: The SmartFinder display settings dialog box.

Under Curve display settings either the raw data (Melt curves) or the derived Peak curves can be selected
for display.

The Control display settings deal with the way that the negative controls are being treated. Three different
options are available:
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• Ignore controls: Negative controls are displayed nor subtracted.

• Show controls in overlay: The negative control for each sample is displayed as a green curve on the
plot.

• Subtract control from curve: The negative control curve is subtracted from the sample curve before
the sample curve is plotted.

The Axes settings determine the ranges for the X-axis (Temperature) and Y-axes (signal from the ROX, Cy5
or BHQ channels) used on the plots. The default setting is Dynamic axis ranges, which uses the minimum
and maximum values of the currently plotted samples as respectively the lower and upper limits for the axis
ranges. When Fixed axis ranges is checked, lower and upper limits can be entered for Temp (= X-axis),
ROX, Cy5, and BHQ. By pressing the <Set to current range>, the minimum and maximum values of the
currently plotted samples are automatically filled in.

To set a sensible fixed axis range for a complete data file, first select all samples from the file
and display the corresponding curves on the plot as an inactive overlay with Analysis > Toggle
overlay selected ( ). Next, call the display settings again, check Fixed axis ranges and press
<Set to current range>.

In addition to the negative controls, it can be useful to display other samples in overlay of the currently
active sample. This makes it easier to discriminate ”real” peaks from background noise in case of low
signals. Selected samples can be shown in an inactive overlay with Analyze > Toggle overlay selected or
by pressing the button. Executing the command again removes the overlay from display.

3.3 Automatic calling

During import (see 2), samples are automatically called. In the SmartFinder analysis window, an automatic
calling can be performed via Analysis > Automatic calling. The SmartFinder analysis settings dialog box
(see Figure 3.4) will pop up.

(a) (b)

Figure 3.4: The SmartFinder analysis settings dialog box, showing the optimized settings
for LightCycler 480 (a) and Rotor-Gene data (b).

The Detection threshold can vary from 0 to 1 and is a parameter for peak shape. The lower this value, the
more sensitive the algorithm becomes for peaks, i.e. even shapes that differ only slightly from a straight line
will be considered as peaks.
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The Actual Tm tolerance determines how much the peak position can vary from the Actual Tm as set during
melt temperature calibration (see 3.5). For example, the default setting of 3◦ Celsius means that peaks are
searched in the range ActualTm −1.5◦C ≤ Tm ≤ ActualTm +1.5◦C.

With the Max. peak width setting, probe peaks can be discriminated from background elevations. The Max.
peak width is measured as the full peak width at half height. Any peak that is wider than this value, will be
disregarded.

The Min. peak valley depth is used to discriminate overlapping peaks, originating from two neighboring
probes. This parameter is expressed as a fraction of the smallest peak height.

Using Min. peak height ROX, Min. peak height Cy5 and Min. peak height BHQ, absolute thresholds can
be entered for peak detection in the respective channels. Peak heights are measured as the distance of the
top of the peak to the local background signal.

When the option Subtract control curve first is checked, the negative control curve is subtracted from the
sample curve prior to peak detection. When negative control curves are available, it is highly recommended
to check this option as it will improve automatic peak detection. For detection of the IAC peak, the negative
control is never subtracted.

With <Reset to Default>, all settings will be reset to their default values, i.e. the settings as displayed in
Figure 3.4 (a).

3.4 Manual calling

Since an automatic calling is prone to errors, the result should be verified visually and – if needed – the calls
should be manually adjusted.

By clicking on a sample in the Entries panel or by using the up or down arrows on the keyboard, the Analysis
panel is updated with the curves of the highlighted sample.

A call can be modified manually by clicking on the probe position in the corresponding curve to highlight it
and selecting Analysis > Change call (selected pathogen). Alternatively, simply hold the Ctrl-key on the
keyboard and click the probe position to toggle the call.

When a call is changed, the changes are immediately propagated to the database.

3.5 Calibrating melting temperatures

The observed melting temperatures of the probes in the mix varies from the theoretical melting temperatures
by an extent that is dependent on the apparatus used. Therefore, the first time a positive control sample is
run, the melting temperatures need to be calibrated. After an overhaul of the PCR apparatus, it might be
necessary to repeat this calibration.

First, a set of positive control samples needs to be imported (see 2 for instructions).

Next, select Analysis > Calibrate melting temperatures to pop up the Calibrate melt temperatures dialog
box (see Figure 3.5).

The dialog box displays for each probe in the probe mix its name (’Pathogen’), the fluorophore used (’Label’,
i.e. ROX, Cy5 or BHQ), the theoretical melting temperature or Tm (’Tm’), the observed Tm (’Actual Tm’)
that was used to determine the probe positions, the Tm that was calculated on the currently loaded samples
(’New Tm’), the difference between the theoretical Tm and the new Tm (’Tm shift’), and the number of
measurements on which the new Tm is calculated (’# calibs’). The columns ’New Tm’ and ’Tm shift’
(highlighted in yellow) can be edited and are synchronized: editing either field will dynamically update the
other. Manual editing allows fine-tuning of the probe positions and/or adjusting the melting temperature of
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Figure 3.5: The Calibrate melt temperatures dialog box.

probes for which there is no positive control sample available.

Pressing <OK> will update the ’Actual Tm’ values and therefore the probes positions (green and red
vertical lines) in the melting curves.

To exit the Calibrate melt temperatures dialog box without making any changes, press the <Cancel> button.

The actual Tm can also be set in the ’Actual Tm’ character information field in the Character
type window of the character type experiment that is named after the SmartFinder kit. If the Tm

of a single probe needs to be adjusted, this editing method is actually more convenient than via
the Calibrate melt temperatures dialog box.

3.6 Reporting options

The Report panel shows a detailed report for an individual sample, in casu the highlighted entry in the
Entries panel (see Figure 3.6). When the active entry in the latter panel is changed, the Report panel is
updated to reflect this change.

The Patient info in the report consists of active information fields in the Entries panel of the SmartFinder
analysis window. Please note that setting the active fields for the Entries panel will only result in an updated
Report panel after highlighting a different entry.

The SmartFinder results section summarizes the test by listing all pathogens for which the sample was
found positive.

More detailed results are reported in the SmartFinder analysis section:

• Automatic calling settings lists the version of the calling algorithm and all settings used (see 3.3) at
the moment the automatic call was performed.
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Figure 3.6: The Report panel in the SmartFinder analysis window.

• Manual calls will list each manual override of a call (see 3.4).

• Data indicates the outcome (positive or negative) for each of the tests using colors. Furthermore, the
name of the detected pathogen, reaction (Mix 1 or Mix 2), fluorescent label and actual Tm used for
automatic calling are indicated for each test. As a visual check for the calling, miniatures of the plots
from the Analysis panel (see 3.1) are included.

Positive tests are red and negative tests are green. However, these default colors can be changed
in the character type settings, if required.

The content from the Analysis panel (i.e. the plots for the currently highlighted sample) can be exported as
an enhanced metafile to the Windows clipboard with File > Copy analysis to clipboard. From the clipboard,
it can then be pasted into Microsoft programs such as e.g. Word or PowerPoint.



3.6. Reporting options 19

Similarly, the content from the Report panel can be exported with File > Copy report to clipboard. This
can be useful to produce customized reports with specific headers and footers, i.e. containing the logo of the
hospital, contact information of the lab, etc..

A report can also be printed directly with File > Print report, which will display a dialog box with the
printer settings.
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